Sunday, September 14, 2014

MPLS command line interface (implementation)

MPLS topology


The most busiest terminal for MPLS is PE (provider edge routers).
Multiple customer links may connect to a PE.
The core network, P to PE routers, uses OSPF/EIGRP for connectivity (in this example).
The following are the step-by-step on MPLS implementation.

!step-1 enable mpls globally and interface level:
!similar logic apply to all PE:
R1-PE(config)# ip cef
R1-PE(config)# mpls label range 100 999
R1-PE(config)# mpls ip

R1-PE(config)# interface GigabitEthernet 1/0
R1-PE(config-if)# mpls ip

====================================================

!step-2 creating vrf:
!similar logic apply to all PE:
R1-PE(config)# vrf definition x.x.x.x:abc
R1-PE(config-vrf)# rd 1.1.1.1:1
R1-PE(config-vrf)# address-family ipv4
R1-PE(config-vrf-af)# route-target export 1.1.1.1:101
R1-PE(config-vrf-af)# route-target import 5.5.5.5:101
R1-PE(config-vrf-af)# exit

you may use "vrf definition x.x.x.x:abc" or "ip vrf x.x.x.x:abc"
"vrf definition x.x.x.x:abc" supports both ipv4 and ipv6
"ip vrf x.x.x.x:abc" supports ipv4 only
====================================================

!step-3 assign vrf to specific interface (customer facing) :
!similar logic apply to all PE:
R1-PE(config)# int fa2/0
R1-PE(config-if)# description connection to customer site 1
R1-PE(config-if)# vrf forwarding x.x.x.x:abc
R1-PE(config-if)# ip address 172.16.101.1 255.255.255.252
R1-PE(config-if)# no shut


!step-4 assign vrf to specific interface (customer facing) :
!similar logic apply to all PE:
R5-PE(config)# int fa3/0
R5-PE(config-if)# description connection to customer site 2
R5-PE(config-if)# vrf forwarding x.x.x.x:abc
R5-PE(config-if)# ip address 192.168.101.1 255.255.255.252
R5-PE(config-if)# no shut

====================================================

!step-5 setup CE (customer edge 1)
!!similar logic apply to all CE:
customer-edge-1(config)# int fa2/0
customer-edge-1(config-if)# description connection PE
customer-edge-1(config-if)# ip address 172.16.101.2 255.255.255.252
customer-edge-1(config-if)# no shut
customer-edge-1(config)# ip route 0.0.0.0 0.0.0.0 172.16.101.1 

====================================================

!step-6 setup routing / static route / BGP / EIGRP / OSPF ...
!redistribution / route leaking ...
!!similar logic apply to all PE:

!static route
ip route vrf 1.1.1.1:abc 172.16.101.0 255.255.255.0 172.16.101.2

---------------------------------------------------------------------------------------
!EIGRP
router eigrp 1

 address-family ipv4 vrf yyy autonomous-system 102
  redistribute bgp 65536 metric 1 1 1 1 1
  network 172.16.0.0
 exit-address-family

router ospf 101 vrf xxx
 redistribute bgp 65536 subnets
 network 172.16.101.1 0.0.0.0 area 0

---------------------------------------------------------------------------------------
!BGP
router bgp 65536
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 65536
 neighbor 5.5.5.5 update-source Loopback0
 !
 address-family vpnv4
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf 1.1.1.1:abc
  redistribute ospf 101
 exit-address-family
 !
 address-family ipv4 vrf 2.2.2.2:xyz
  redistribute eigrp 102
 exit-address-family
=======================================================

Notes:
most commonly uses ROUTING PROTOCOLS @ CE are :
  • STATIC ROUTE 
  • BGP

Route leaking is uses, when 2 different (VPN) customers want to share their resources. 
It can be all of the routes or specific routes only.

No comments:

Post a Comment