Monday, July 16, 2012

Inter VLAN routing with Layer 3 switch

Inter VLAN routing with Layer 3 switch
Components Used
1x layer 3 switch cisco 3550
2x layer 2 switch cisco 2960
1x server (use PC as file server if no server available)
1x PC

SW1 (layer 3 switch)

vlan 2
name user
interface vlan 2
ip address 10.1.2.1 255.255.255.0

vlan 3
name server
interface vlan 3
ip address 10.1.3.1 255.255.255.0

vtp domain cisco
vtp password cisco

interface Gi0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shut

interface Gi0/2
switchport trunk encapsulation dot1q
switchport mode trunk
no shut
exit

ip routing


SW2 (Layer 2 Switch)

no ip routing
vtp domain cisco
vtp password cisco

interface Gi0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shut

SW3 (Layer 2 Switch)

no ip routing
vtp domain cisco
vtp password cisco

interface Gi0/1
switchport trunk encapsulation dot1q
switchport mode trunk
no shut


PC and servers Assign static ip accordingly

***Testing steps
ping pc to pc (same vlan)
ping pc to pc (different vlan)
ping pc to server

Note;
Layer 2 switch model = Cisco catalyst 2960
Layer 3 switch model = Cisco catalyst 3550 or 3760

Layer 2 switch is only do "Forwarding", which means cannot communicate different VLANs.
example, PC from VLAN 2 can't ping to PC at VLAN 3.

In Layer 3 switch,
create "interface vlan with ip address".
type "ip routing" to turn ON "interVLAN routing"
with this feature set, different VLANs are able to communicate each others.

we can replace Layer 3 switch with a Router , see Router on a stick  

No comments:

Post a Comment